God Bless the creators of the Game Dr.!

genjuro1

Ninja Combat Warrior
Joined
Sep 11, 2004
Posts
547
So, I bought Marvel vs Capcom 1 for the Dreamcast off Ebay.
The description said that the game works. Good enough for me.

It comes in the mail, and was horribly scratched. I thought to myself, "My 4 year old Game Dr. aint gonna correct this. I better get it done at one of the places I know does disk repair with a professional grade machine."
I called 3 different places, and they all said the same thing, that they don't repair Dreamcast games because after the process, the game will probably not work. So, I thought to myself "I've used the Game Dr. on a Dreamcast game before and had no problems. Let's give it a try."

I ran the disk through the process twice. Put it in my Dreamcast, and the game worked. But in the middle of my first fight, the game froze on me. After that, the game wouldn't load up at all. I then put in 2 other Dreamcast games that I own that are in Very Good to Mint condition; and just like I thought, no problems at all. My Dreamcast is not malfuntioning.

After trying about 10 times to get it to load, and failing, I am now I'm MAD! I'm ready to email the seller requesting my money back, and order another game.
So then I thought to myself "let me go the whole 9 yards before I do that." I wipe the disk with 70% alcohol, and clean my Dreamcast's lens with a q-tip dipped in alcohol. Still, the game wouldn't load. I run it through the Game Dr. 2 more times and Boom! The game worked! Beat it twice, played all the game modes, no problems.

If I didn't have the Game Dr. I would have been SOL. I plan on buying a new Game Dr. next week, cause after 4 years, and the work it had to go through fixing that horribly scratched up disk, it's time to retire my old one.
 

Lagduf

2>X
20 Year Member
Joined
Dec 25, 2002
Posts
43,436
Did you try the game before you ran it through the disc doctor?
 

not sonic

King of Typists,
15 Year Member
Joined
Dec 12, 2003
Posts
9,326
i once had my copy of doa2 for dc resurfaced.

before resurfacing it would just crash when it tried to access the data near the scratch.

now it doesnt work at all.
 
Top