Cyber-Lip Video corruption

KRiSX

King's Dry Cleaner
Joined
Jul 29, 2013
Posts
376
hey guys, any suggestions on if this is fixable?



guessing it could be a bad solder? either that or a chip is bad?

may just use the shell for something else
 
Last edited:

Xian Xi

JammaNationX,
15 Year Member
Joined
Dec 1, 2005
Posts
27,725
It's hard to say, looks like it needs to be reseated in the slot. I know on the older games the Omega cart slot is too tight. Try moving the cart while it's in the slot, do not remove it just move it back and forth to see if the graphics clear up.
 

KRiSX

King's Dry Cleaner
Joined
Jul 29, 2013
Posts
376
How did you clean it?

i believe i used methylated spirits and a cotton bud... was either that or windex and a cotten bud... it certainly got some crap off the pins but didn't make any difference... FYI it was doing this before i tried cleaning it so i know i'm not to blame lol
 

Jibbajaba

Ralfredacc's Worst Nightmare
10 Year Member
Joined
Apr 30, 2009
Posts
5,612
Please open the cart and clean the contacts with, at minimum, an eraser until they look completely clean. If you can get some de-oxit, that would be a great finishing move after the eraser.
 

wyo

Kyo's Flame
10 Year Member
Joined
May 22, 2013
Posts
8,428
Please open the cart and clean the contacts with, at minimum, an eraser until they look completely clean. If you can get some de-oxit, that would be a great finishing move after the eraser.

I had similar problems with my copy and this did the trick. If the basic isopropyl + Q-tip doesn't work, always open the cart for a more thorough inspection and cleaning.
 

Xian Xi

JammaNationX,
15 Year Member
Joined
Dec 1, 2005
Posts
27,725
Clean it with the eraser first then push it straight down into the machine and then pull the back of the cart forward about 3mm. That should clear it up.
 

KRiSX

King's Dry Cleaner
Joined
Jul 29, 2013
Posts
376
I had similar problems with my copy and this did the trick. If the basic isopropyl + Q-tip doesn't work, always open the cart for a more thorough inspection and cleaning.

yeah i didn't try with an eraser... haven't actually got one, haha, but i'll go buy one and see how that goes... i did open it up when i was doing it the first time

will give this a try n see how it goes... cheers guys


EDIT: ok, so some minor improvements after hitting it with an eraser but something is still not right... i might invest in some deoxit and see if that helps
 
Last edited:
Top