Help with AES (fresh outta storage)

BryLmoo

AES Contact Cleaner, Extraordinaire!!!,
20 Year Member
Joined
Aug 22, 2000
Posts
3,634
Okay, so...I took my trusty AES outta storage because I was craving some sam sho, and...glitch city. I see a garbled mess when I turn the system on, and sometimes it just seems to stop working altogether. Seems like it might be something fixed by cleaning....but I'm not so sure... :help:
 

HMG

H = Heinously, M = Massive, G = Gonad,
10 Year Member
Joined
Apr 3, 2011
Posts
5,063
First thing to do is clean your Samurai Shodown cartridge and the system slot. The quick n dirty solution is to use the SamSho cart as a cleaning tool with rubbing alcohol and cotton swabs, which will at least get rid of the dust. Clean the SamSho cart first, then wet its edge connectors and use that to scrub the cartridge slot. Do that a few times, wait a few minutes for the slot and cart to dry then test again.
 

wyo

The Cable Guy
10 Year Member
Joined
May 22, 2013
Posts
8,050
Go to Walmart or Home Depot and pick up some QD Contact Cleaner. It's an aerosol so you can spray into your cart slot and on the cart contacts. If dirt/corrosion is the issue, this is the easiest fix and a better choice than isopropyl.
 

BryLmoo

AES Contact Cleaner, Extraordinaire!!!,
20 Year Member
Joined
Aug 22, 2000
Posts
3,634
I'm just a little hesitant to wet the cart connectors lol. I've used isopropyl before...never heard of the contact cleaner...but I'm not opposed to trying it lol
 
Last edited:

HMG

H = Heinously, M = Massive, G = Gonad,
10 Year Member
Joined
Apr 3, 2011
Posts
5,063
If you can't get contact cleaner, isopropyl alcohol works okay in a pinch. Alcohol evaporates very quickly, there's no risk to getting the cart connectors wet with alcohol as long as you let it all dry before powering anything up. Don't use 70% or lower alcohol, takes too long to evaporate.
 

BryLmoo

AES Contact Cleaner, Extraordinaire!!!,
20 Year Member
Joined
Aug 22, 2000
Posts
3,634
I will give it a shot! Thanks guys
 

BryLmoo

AES Contact Cleaner, Extraordinaire!!!,
20 Year Member
Joined
Aug 22, 2000
Posts
3,634
I am good! Hope you are? I'll be back on later..
 

Rot

Calvin & Hobbes, ,
Joined
Jul 8, 2003
Posts
11,445
I am good! Hope you are? I'll be back on later..

I'll prob be in bed pal... HOWEVER:

Screen%20Shot%202017-04-22%20at%2022.09.23_zpslm3xjbd7.png


xROTx
 

bubba966

Cinema Ninja!,
Joined
Sep 24, 2013
Posts
1,537
Go to Walmart or Home Depot and pick up some QD Contact Cleaner. It's an aerosol so you can spray into your cart slot and on the cart contacts. If dirt/corrosion is the issue, this is the easiest fix and a better choice than isopropyl.

This. So much this. I usually go buy it at the auto parts store as that's far closer and easier than wallyworld or home cheapo. For reference it looks like this
p12517Z.jpg


90+% isopropyl alcohol is ok for dust and some surface dirt. But honestly it's not very good at any tarnish/oxidation/corrosion removal. Only time I use isopropyl is to aid in drying off a pcb that I've washed. Wash in soap and warm water, rinse with isopropyl, then air dry on edge. Any and all contact cleaning is done with the QD contact cleaner pictured above.
 
Last edited:

evil wasabi

The Jongmaster
20 Year Member
Joined
Aug 20, 2000
Posts
60,435
Is there a debug bios installed in the system?

Sometimes the bios chip will become dislodged and the Neo will display the symptoms you described.
 

BryLmoo

AES Contact Cleaner, Extraordinaire!!!,
20 Year Member
Joined
Aug 22, 2000
Posts
3,634
Nope, not modded. I'm going to try and get some of this contact cleaner and see if it does the trick...
 

BryLmoo

AES Contact Cleaner, Extraordinaire!!!,
20 Year Member
Joined
Aug 22, 2000
Posts
3,634
Okay... Tried the contact cleaner. Seems to have worked somewhat. I'm now getting a blue screen when I boot the system without a cart. Whenever I insert a game, however, it's still a jumbled mess. I guess I can spray some more of the contact cleaner on both the game and system contacts? I'm dumbfounded ��
 

BryLmoo

AES Contact Cleaner, Extraordinaire!!!,
20 Year Member
Joined
Aug 22, 2000
Posts
3,634
It's my only system lol
 

Neodogg

Dogg-Father,
20 Year Member
Joined
Nov 27, 2002
Posts
4,523
How about a couple Picts of what you're working with?

Side bar is so 2005...
 

HMG

H = Heinously, M = Massive, G = Gonad,
10 Year Member
Joined
Apr 3, 2011
Posts
5,063
Okay... Tried the contact cleaner. Seems to have worked somewhat. I'm now getting a blue screen when I boot the system without a cart. Whenever I insert a game, however, it's still a jumbled mess. I guess I can spray some more of the contact cleaner on both the game and system contacts? I'm dumbfounded ��

That means the cartridge slot is still dirty, possibly your test game too. Try my suggestion, wet the cartridge edge connectors with alcohol using q-tips, then scrub the cart slot with the cartridge, clean off the edge connectors, rinse and repeat until the cartridge doesn't come out dirty anymore.
 
Top