NeoGeo CD SD Loader

titchgamer

Guerilla Warrior
Joined
May 31, 2018
Posts
1,730
Awesome!
Still not got to mine!
Been far to busy the last few days and its buried behind a wall of boxes atm lol
 
Last edited:

ashram

CompUSA-4-Life, ,
Joined
Apr 15, 2002
Posts
211
So, I have been severely neglecting my CD for well over a decade (I started pulling out my consoles after a divorce and the SD loader made me want to go back to my neo cd)... Well, after installing the Sd loader and booting an actual CD (Pulstar) I get some cd audio distortion after 30+ minutes, but if I power cycle the unit, I noticed some flickering on all splash screens and eventually it crashes (image attached) but if I let it sit for 30+ minutes, it's fine again. If I power cycle in 5-10 minutes after a cold boot, same flickering and crash. It is a Japanese top loader and using a 120-100 step-down. Power supply has been recapped and voltage seems stable. Thoughts? broken.jpg
 

edd_jedi

Kabuki Klasher
Joined
Oct 28, 2018
Posts
123
Sorry I haven't seen that, but there is a known issue of poor contacts with the CPU connector, if you look a couple of pages back you'll see that mine had to be replaced.
 

ashram

CompUSA-4-Life, ,
Joined
Apr 15, 2002
Posts
211
Hoping that's not the issue. Got my sd loader like 2-3 weeks ago. Suppose I forgot to mention that when the graphics start flickering, I can get that error in both loading SD Loader and Neo cd bios as well as during gameplay
 

Burning Fight!!

NIS America fan & Rent Free tenant
Joined
Jan 12, 2014
Posts
2,419
If anyone is looking for a version of Super Sidekicks 3 that doesn't error 0003 out, PM me. I dumped a copy from a CD-R someone burned 20 years ago lol

edit2: went ahead and edited out my posts, doesn't seem to be a hardware problem on my end at all. Enjoying a lot of the SD loader! I had no idea CD games also had softdips but it seems like most games set them up but don't give a fuck on what's in them if there's an in-game selector. Metal Slug lets you enable blood but won't budge on other options like difficulty for instance.

Magician Lord (the game I mostly play) actually uses all the damn dip switches and you can put it up to Level-8, set up the timer, lives, bonus, etc. on it, which is a real plus! And lol at the CD native difficulty being Level-1.
 
Last edited:

wyo

The cable guy
Joined
May 22, 2013
Posts
7,598
I installed the SD loader and kept the CD drive. Now when playing games from a CD, I just get sound effects, no CD audio. Any ideas on why this is?
 

CORY

stand by we're experiencing technical difficulties
Staff member
Joined
Dec 10, 2001
Posts
5,399
I installed the SD loader and kept the CD drive. Now when playing games from a CD, I just get sound effects, no CD audio. Any ideas on why this is?


"On remonte le tout en n'oubliant pas de raccorder le CDDA, sinon pas de musique CD"

Found this on the french forums. Check if your CDDA cable is connected properly.
 
  • Like
Reactions: wyo

wyo

The cable guy
Joined
May 22, 2013
Posts
7,598
"On remonte le tout en n'oubliant pas de raccorder le CDDA, sinon pas de musique CD"

Found this on the french forums. Check if your CDDA cable is connected properly.

Thanks Cory! Yeah, I knew it had to be something with the CDDA. I had wired the bypass from the CN3 connector pins on underside of the main board to the SD Loader. Well, underneather the main board is a metal heat shield. I think one or more of the wires were shorting out. Added some electrical tape to shield and it solved the problem :)
 

CORY

stand by we're experiencing technical difficulties
Staff member
Joined
Dec 10, 2001
Posts
5,399
Thanks Cory! Yeah, I knew it had to be something with the CDDA. I had wired the bypass from the CN3 connector pins on underside of the main board to the SD Loader. Well, underneather the main board is a metal heat shield. I think one or more of the wires were shorting out. Added some electrical tape to shield and it solved the problem :)
Glad to help! :buttrock:
 

Burning Fight!!

NIS America fan & Rent Free tenant
Joined
Jan 12, 2014
Posts
2,419
In case anyone hasn't seen, he is now working on the front loader version, apparently available in the next few months.
Him stopping selling it altogether gave me the impression he was sick and tired of doing it because of support. Surprising he's still working on it.
 

Cowabunga

Bashful Neophyte
Joined
Mar 25, 2011
Posts
11
So, I have been severely neglecting my CD for well over a decade (I started pulling out my consoles after a divorce and the SD loader made me want to go back to my neo cd)... Well, after installing the Sd loader and booting an actual CD (Pulstar) I get some cd audio distortion after 30+ minutes, but if I power cycle the unit, I noticed some flickering on all splash screens and eventually it crashes (image attached) but if I let it sit for 30+ minutes, it's fine again. If I power cycle in 5-10 minutes after a cold boot, same flickering and crash. It is a Japanese top loader and using a 120-100 step-down. Power supply has been recapped and voltage seems stable. Thoughts? View attachment 46372
I get a similar issue, I did not mod my SD Loader a retro game company did.

Not so much a problem with flickering or splash screens, however after leaving certain games on (keyword here being CERTAIN games) I get garbled audio. Whenever I leave games like Fatal Fury 3, Real Bout Special, KOF '95 and '98 on for an hour and 10 minutes the games get very annoying static. In Fatal Fury 3's case I notice this after leaving the game on for an hour then playing through it until the 2nd or 3rd stage. Meanwhile games like Breakers and Burning Fight I don't have this problem. Hell I left both games on for 2 hours and the audio was silky smooth.

What could the problem be? I contacted Furrtek about this and got radio silence. I prey it's not a problem with the CPU socket since something like that would bring me great grief, leading me to send the Loader back. I would like to exhaust all other potential options first, for instance, why is it the problem copy protected games like the KOF games and Fatal Fury 3 nuke my audio however Breakers and Burning Fight don't? That's what makes me hesitate before returning the Loader for repairs to get a new socket. Could it be the way I packaged the roms? I created the CDDA files in bin+cue, iso+cue with multi bin, and clone CD. Made sure to make the tracks 16-pcm wave at 14400 Hz using Audacity. All boot up, none keep the audio functioning.

I have a couple of copy protection hack files for aforementioned games, tried different copy protected files yet the sound problem persists. Please help!
 
Last edited:

wyo

The cable guy
Joined
May 22, 2013
Posts
7,598
You could try playing the games instead of leaving the system on for hours looking for problems.
 

Cowabunga

Bashful Neophyte
Joined
Mar 25, 2011
Posts
11
You could try playing the games instead of leaving the system on for hours looking for problems.
I'm not looking for problems smartass I'm trying to get the thing working.

FYI there was bad audio when playing too.
 

wyo

The cable guy
Joined
May 22, 2013
Posts
7,598
I'm not looking for problems smartass I'm trying to get the thing working.

FYI there was bad audio when playing too.
You said the problems arose after leaving the system on for an hour. Didn't seem like a big deal since you can play through the entire game in well under an hour.

According to furrtek, "the loader doesn't circumvent any anti-piracy features since the NeoGeo CD doesn't have any. However, some games implement copy-protection measures that may be triggered. Patches exist."

That's all I got, sorry.
 

Cowabunga

Bashful Neophyte
Joined
Mar 25, 2011
Posts
11
You said the problems arose after leaving the system on for an hour. Didn't seem like a big deal since you can play through the entire game in well under an hour.

According to furrtek, "the loader doesn't circumvent any anti-piracy features since the NeoGeo CD doesn't have any. However, some games implement copy-protection measures that may be triggered. Patches exist."

That's all I got, sorry.
Thank u

Yeah, I wasn't trying to imply I "only" let the demo play. Of course when we all buy a neo geo we do it to play the shit. Perhaps most on this forum can beat these games in under an hour. I've stopped playing fighting games a long time ago (roughly 10 years) I recently got back into it and am rusty as hell. So yeah it's taking me longer than an hour to beat these games.

EDIT: Forgot to mention, I was already aware of the copy protection bullshit. I have hacked/unprotected versions of the aforementioned games. The I/O ERROR and anti-piracy messages are not what's at issue here. Unless your trying to say that the copy protection being removed is some how causing the bad audio?
 
Last edited:

Burning Fight!!

NIS America fan & Rent Free tenant
Joined
Jan 12, 2014
Posts
2,419
There's absolutely no mechanism that a game could use to garble CDDA. CD units in these systems, excluding game data loading of course, are basically jukeboxes, the game just tells the drive to play an audio track and that's it.

Maybe something is wrong with your unit, maybe it's a firmware issue. Have you tried downgrading to a previous version? You don't necessarily need to use the older unstable ones, but I think the previous update worked just as fine IIRC. Try reproducing the error in that firmware. Honestly this sounds like an inherent flaw of the SD Loader more than anything.

As soon as I get time I'll try to play KOF 98 for an extended period of time to see if I have your issues.
 

Cowabunga

Bashful Neophyte
Joined
Mar 25, 2011
Posts
11
There's absolutely no mechanism that a game could use to garble CDDA. CD units in these systems, excluding game data loading of course, are basically jukeboxes, the game just tells the drive to play an audio track and that's it.

Maybe something is wrong with your unit, maybe it's a firmware issue. Have you tried downgrading to a previous version? You don't necessarily need to use the older unstable ones, but I think the previous update worked just as fine IIRC. Try reproducing the error in that firmware. Honestly this sounds like an inherent flaw of the SD Loader more than anything.

As soon as I get time I'll try to play KOF 98 for an extended period of time to see if I have your issues.
Alright! That's the best news I heard all morning. Yeah I was hoping some on this forum could test these problem games and see if they get the same results. Call it a process of elimination! The main ones giving me the most problems are all Fatal Fury 3 and all three Real Bouts AWA all the KOFs (especially '95!)

My theory is the problem will wind up being the firmware, the way I repackaged these roms with security removed, or in the most extreme cases a hardware issue involving either the SD Loader or the board (CPU socket). I absolutely dread it being a hardware issue because I'd need to send back and pay the shipping on a $500 dollar console. It's ashame since none of my other console mods stemming from the DC GDEMU, PSX PSO, Saturn Phoebe, all the way down to the 3DO MNEMO never gave me any problems nor did any of my flash carts (NeoSD. Mega SD, etc.) The streak has been broken by the NGCD SD Loader lol.

I'll attempt to downgrade firmware when I get some time, appreciate the suggestion.
 

Cowabunga

Bashful Neophyte
Joined
Mar 25, 2011
Posts
11
So I downgraded all the way down to Firmware v0.5 and guess what? The crap audio started sooner! Rather than 30 minutes it started tearing after 5 minutes. I'm truly baffled by this. After re-reading this thread I'm beginning to wonder if this really is an issue with the Loader. The CPU socket & CDDA stuff I red about, focused on the lack of music while playing from a CD on one issue, and trouble updating the Loader on another issue. Looks like only ashram shares my problem.

Hopefully someone here can try one of these copy-protected games and see if they encounter my sound issue. If it's universal then it's a problem with the Loader and nothing flawed on my end.
 

yoshi41

Overtop Pathfinder
Joined
Dec 29, 2012
Posts
102
Yeah I was hoping some on this forum could test these problem games and see if they get the same results. Call it a process of elimination! The main ones giving me the most problems are all Fatal Fury 3 and all three Real Bouts AWA all the KOFs (especially '95!)

Played through (patched) RBS a couple of times. Left the console on for about 3 hours. No issues at all.
 
Top